
 

第 7 章  数码管显示电路原理图绘制 

任务描述 

本章主要内容介绍数码管显示电路原理图（如图 7-1 所示）的绘制。在该原理图中，首先

调用第6章建立的原理图图纸模板，然后调用第4章建立的原理图库内的两个元件：AT89C2051
单片机和数码管。通过该电路图验证建立的原理图库内的两个元件的正确性，并进行新知识的

介绍，它将涵盖以下主题： 
 导线的放置模式、放置总线及总线引入线 
 原理图对象的编辑 
 Navigator 面板、SCH Inspector 面板、SCH List 面板 

通过对本章的学习，使学生将能够更加快捷和高效地使用 Altium Designer 的原理图编辑

器进行原理图的设计。 

 
图 7-1  数码管显示器电路原理图 

7.1  数码管原理图的绘制 

7.1.1  绘制原理图首先要做的工作 
首先在硬盘上建立一个名为“数码管显示电路”的文件夹，然后建立一个“数码管显示
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电路.PrjPCB”项目文件并把它保存在“数码管显示电路”文件夹下，新建一个原理图，调用

第 6 章建立的原理图图纸模板，调用方法已在 6.5.2 中介绍，在此不赘述，并把原理图另存为

“数码管显示电路.SchDoc”。 
在原理图上右击，在弹出的菜单中选择 Options→Document Parameters 命令，打开

Document Options 对话框，选择 Units 标签，勾选 Use Imperial Unit System（使用英制单位）

复选框；选择 Sheet Option 标签，设置 Grid（栅格），Snap：50mil，Visible：100mil，Electrical 
Grid：30mil。 

选择 Parameters 标签，修改 Parameters 选项卡内的参数列表的内容，将参数 Title 的内容

改为原理图的名称：数码管显示电路；将参数 Author 的内容设置为设计者的姓名：刘明；将

参数 ApprovedBy 的内容设置为：李思进；将参数 Technologist 的内容设置为：徐丹丹；将参

数 Normalizer 的内容设置为：李力；将参数 Ratifier 的内容改为设置为：邓勇前；将参数

CompanyName 的内容改为：重庆森伟电子公司；将参数 SheetNumber 的内容改为：

BD2.898.000DL；然后单击 OK 按钮。设计好的原理图图纸如图 7-2 所示。 

 
图 7-2  原理图图纸 

7.1.2  加载库文件 

Altium Designer 为了管理数量巨大的电路标识，电路原理图编辑器提供强大的库搜索功

能。首先在库面板查找 MAX1487E 和 74LS49 两个元件，并加载相应的库文件。然后加载在

第 5 章建立的集成库文件：New Integrated_ Library1.IntLib。 
1．查找型号为 74LS49 元件 
（1）单击 Libraries 标签，显示 Libraries 面板，如图 7-3 所示。 
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（2）在 Libraries 面板中单击 Search 按钮，或选择 Tools → Find Component 命令，将打

开 Libraries Search 对话框，如图 7-4 所示。 

 
图 7-3  Libraries 面板 

（3）对于本例必须确认在 Scope 设置中，Search in 选择为 Components（对于库搜索存在

不同的情况，使用不同的选项）。必须确保 Scope 设置中，选择 Libraries on path 单选按钮，并

且 Path 包含了正确的连接到库的路径。如果用户接受安装过程中的默认目录，路径中会显示

C:\Program Files\Altium Designer Winter 09\Library\。可以通过单击文件浏览按钮来改变库文件

夹的路径。还需要确保已经选中 Include Subdirectories 复选框。 
（4）我们想查找所有与 74LS49 有关的元件，所以在 Filters 的 Field 列的第 1 行选 Name，

Operator 列选 Contains，Value 列输入 74LS49，如图 7-4 所示。 

 
图 7-4  “库搜索”对话框 
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（5）单击 Search 按钮开始查找。搜索启动后，搜索结果如图 7-5 所示。 

 
图 7-5  搜素结果 

（6）单击 Place SN74LS49D 按钮，弹出 Confirm对话框，如图 7-6 所示，确认是否安装元件

SN74LS49D 所在的库文件 TI Interface Display Driver.IntLib，单击 Yes 按钮，即安装该库文件。 

 
图 7-6  确认是否安装库文件 

（7）用以上方法查找 MAX1487E 元件。 
2．安装第 5 章建立的集成库文件 New Integrated_Library1.IntLib 
（1）如果用户需要添加新的库文件，单击图 7-3 中库面板的 Libraries 按钮，弹出

Available Libraries 对话框，如图 7-7 所示。 

 
图 7-7  安装库文件对话框 
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（2）在 Available Libraries 对话框中，单击 Install 按钮，弹出打开路径的对话框，如图 7-8
所示，选择正确的路径，双击需要安装的库名即可。 

 
图 7-8  安装库文件 

添加的库将显示在库面板中。如果用户单击库面板中的库名，库中的元件会在下面的显

示区中显示。面板中的元件过滤器可以用来在一个库内快速定位一个元件。 
如果需要删除一个安装的库，在 Available Libraries 对话框选中该库，单击 Remove 按钮

即可。 

7.1.3  放置元件 

用第 2 章介绍的方法放置元件。表 7-1 给出了该电路中每个元件样本、元件标号、元件名

称（型号规格）、所在元器件库等数据。注意在放置元件的时候，一定要注意该元件的封装要

与实物相符。 

表 7-1  数码管显示电路元器件数据 

元件样本 元件标号 元件名称 所属元器件库 

AT89C2051 U1  New Integrated_ Library1.IntLib（新建元件库） 

MAX1487EPA U2  Maxim Communication Transceiver.IntLib 

74LS49 U3  TI Interface Display Driver.IntLib 

Dpy Blue-CA DS1～DS3  New Integrated_ Library1.IntLib（新建元件库） 

NPN Q1～Q3 9013 Miscellaneous Devices.IntLib 

XTAL Y1 12MHz Miscellaneous Devices.IntLib 

Cap C1～C2 30P Miscellaneous Devices.IntLib 

Cap Pol2 C3 10U/10V Miscellaneous Devices.IntLib 

Cap Pol2 C4 220U/10V Miscellaneous Devices.IntLib 

Res2 R1～R3 10K Miscellaneous Devices.IntLib 

Res2 R4～R6 5K Miscellaneous Devices.IntLib 

Res2 R7～R9 1K Miscellaneous Devices.IntLib 

Res2 R10～R16 300 Miscellaneous Devices.IntLib 

Header2 P1  Miscellaneous Connectors.IntLib 

Header6 P2  Miscellaneous Connectors.IntLib 
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（1）在放置电容 C1、C2 的过程中，将封装改为 RAD-0.1，方法如下： 
1）在放置 C1 的时候，当光标上“悬浮”着一个电容符号时，按 Tab 键编辑电容的属性。

在 Component Properties 对话框的 Models For C1-Cap 单元，电容的封装模型为 RAD-0.3，如图

7-9 所示，现在要把它改为 RAD-0.1。 

 
图 7-9  为选中元件选择相应的模型 

2）单击 Edit 按钮，弹出 PCB Model 对话框，如图 7-10 所示，在 PCB Library 栏，选中单

选按钮 Any；在 Footprint Model 栏，单击 Browse 按钮，弹出 Browse Libraries 对话框，如图

7-11 所示，在 Mask 文本框内输入 R，下面就列出所有以 R 开头的封装，选择 RAD-0.1 的封

装，单击 OK 按钮，将电容 C1 封装改为 RAD-0.1。 

   
 图 7-10  PCB Model 选择对话框 图 7-11  Browse Libraries 对话框 

3）用同样的方法将 C2 封装改为 RAD-0.1，将 C3 封装改为 CAPR5-5×5；将 C4 封装改为

RB5-10.5。 
在原理图内也可以不修改元器件的封装，用默认的值。然后在 PCB 板内，根据实际元器

件的尺寸修改封装。 
（2）放置好元器件位置的数码管电路原理图如图 7-12 所示。 

7.1.4  导线放置模式 

导线用于连接具有电气连通关系的各个原理图管脚，表示其两端连接的两个电气接点处

于同一个电气网路中。原理图中任何一根导线的两端必须分别连接引脚或其他电气符号。在原

理图中添加导线的步骤如下。 
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图 7-12  放好元件的数码管电路原理图 

（1）在主菜单中选择 Place→Wire 命令，或者单击 Wiring 工具栏中的放置导线工具按钮

。 
此时鼠标指针自动变成十字形，表示系统处于放置导线状态。 
（2）按 Tab 键，打开如图 7-13 所示的 Wire 对话框。 

 
图 7-13  Wire 对话框 

（3）单击 Wire 对话框中的 Color 色彩条，可以改变导线的颜色。单击 符号，弹出下拉

列表，从中选择导线的线宽，在本例中选 Small。设置好后单击 OK 按钮，即进入导线放置模

式，具体放置方法已在前面介绍，在此不赘述。 
（4）放置导线的时候，按 Shift+Space 快捷键可以循环切换导线放置模式。有以下多种

模式可选：①90°。②45°。③自由角度，该模式下导线按照直线连接其两端的电气结点。④

自动连线，该模式是一种提供给用户完成原理图里面两点间自动连接的特殊模式，它可以自

动绕过障碍物走线。在这种模式下，按 Tab 键，可打开如图 7-14 所示的 Point to Point Router…
对话框。 

该对话框用以设置自动布线的规则，其中 Time Out After(s)编辑框用来设置自动布线的

时间限制，这个时间设置得越长，系统的自动布线效果会越好，但花费的时间也就越长。
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系统默认值为“3 秒”。Avoid cutting wires 滑块用于设定自动布线过程中避免与其他线交叉

的要求程度，越向右，则要求越高，相应布线质量也就越好，但布线速度会减慢，花费时

间也增加了。 

 
图 7-14  Point to Point Router 话框 

以上模式规定了放置导线的时候转角产生的不同方法。按 Space 键可以在顺时针方向和逆

时针方向布线之间切换（如 90°和 45°模式），或在任意角度和自动连线之间切换。 
连接导线的原理图如图 7-1 所示。 
在连线过程中，按 Ctrl+鼠标上的滑轮，可以任意放大或缩小原理图；按 Shift+鼠标上的

滑轮，可以左右移动原理图。 
这 4 种布线方式所生成的导线如图 7-15 所示。 

 
 90°模式 45°模式 Any Angle 模式  Auto Wire 模式 

图 7-15  4 种布线模式比较 

7.1.5  放置总线和总线引入线 

在数字电路原理图中常会出现多条平行放置的导线，由一个器件相邻的管脚连接到另一

个器件的对应相邻管脚。为降低原理图的复杂度，提高原理图的可读性，设计者可在原理图中

使用总线（Bus），总线是若干条性质相同的信号线的组合。在 Altium Designer 的原理图编辑

器中总线和总线引入线实际上都没有实质的电气意义，仅仅是为了方便查看原理图而采取的一

种示意形式。电路上依靠总线形式连接的相应点的电气关系不是由总线和总线引入线确定的，

而是由在对应电气连接点上放置的网络标签 NetLab 确定的，只有网络标签相同的各个点之间

才真正具备电气连接关系。 
通常情况下，为与普通导线相区别，总线比一般导线粗，而且在两端有多个总线引入线

和网络标记。放置总线的放置过程与导线基本相同，其具体步骤如下。 
（1）单击 Wiring 工具栏上的放置总线工具按钮 ，或者选择主菜单中的 Place→Bus 命

令（快捷键 P，B），如图 7-16 所示。 
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图 7-16  Place 菜单 

此时鼠标指针自动变成十字形，表示系统处于放置导线状态。鼠标指针的具体形状与

Document Options 中的设置有关。 
（2）按 Tab 键，打开如图 7-17 所示的 Bus 对话框。 

 
图 7-17  Bus 对话框 

（3）在 Bus 对话框中单击 Color 色彩条，打开 Choose Color 对话框。用户可在 Choose 
Color 对话框中设置总线的颜色，选好色彩后，单击 OK 按钮即可。 

（4）在 Bus 对话框的 Bus Width 下拉列表中选择总线的宽度。 
与导线宽度的设置相同，Altium Designer 为用户提供了 4 种宽度的线型供选择，分别是

Smallest、Small、Medium 和 Large，默认的线宽为 Small。总线的宽度与导线宽度相匹配，即

两者都采用同一设置，本例中选择线宽为 Small。如果导线宽度设置比总线宽度大的话，容易

引起混淆。画总线时，总线的末端最好不要超出总线引入线。 
（5）所有与总线相关的选项都设置完毕后，单击 OK 按钮，关闭 Bus 对话框。 
（6）将鼠标指针移动到欲放置总线的起点位置 U3 的右边，单击或按回车键确定总线的

起点。移动鼠标指针后，会出现一条细线从所确定的端点处延伸出来，直至鼠标指针所指位置。 
（7）将鼠标指针移到总线的下一个转折点或终点处，单击或按回车键添加导线上的第二

个固定点，此时在端点和固定点之间的导线就绘制好了。继续移动鼠标指针，确定总线上的其

他固定点，最后到达总线的终点后，先单击或按回车键，确定终点，然后右击或按 Esc 键，完

成这一条总线的放置。 
与导线放置方式相同，Schematic Editor 也为用户提供了 4种放置总线模式，分别是 90°、

45°、自由角度及自动布线模式。通过按快捷键 Shift+空格键可以在各种模式间循环切换。 
仅仅绘制完总线，在原理图中并不代表任何意思，总线无法直接连接器件，还需要为其

添加总线引入线和网络标记，步骤如下。 
（1）单击 Wiring 工具栏中的放置总线引入线工具按钮 ，或者在主菜单选择

Place→Bus Entry 命令（快捷键 P，U）。 
启动放置总线引入线命令后，鼠标指针变成十字状，并且自动“悬浮”一段与灰色水平

方向夹角为 45°或 135°的导线，如图 7-18 所示，表示系统处于放置总线引入线状态。 
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图 7-18  放置总线引入线时的鼠标指针 

（2）按 Tab 键，打开如图 7-19 所示的 Bus Entry 对话框。 

 
图 7-19  Bus Entry对话框 

（3）在 Bus Entry 对话框中单击 Color 色彩条，打开 Choose Color 对话框。在 Choose 
Color 对话框中选择总线引入线的颜色，选好色彩后，单击 OK 按钮即可。 

（4）在 Bus 对话框中单击 Bus Width 下拉列表右侧的 按钮，在弹出的列表中选择总线

引入线的宽度规格。 
与总线宽度一样，总线引入线也有 4 种宽度线型可选择，分别是 Smallest、Small、Medium

和 Large，默认的线宽为 Small，建议选择与总线相同的线型。 
（5）单击 OK 按钮，完成对总线引入线属性的修改。 
（6）将鼠标指针移到将要放置总线引入线的器件管脚处，鼠标指针上出现一个红色的星

形标记，单击即可完成总线引入线的放置，如果总线引入线的角度不符合布线的要求，可以按

空格键调整总线引入线的方向。 
（7）重复步骤（6）的操作，在其他管脚放置总线引入线，当所有的总线引入线全部放

置完毕，右击或按 Esc 键，退出放置总线引入线的状态，此时鼠标指针恢复为箭头状态 。 
（8）单击选中总线，按住鼠标，调整总线的位置，使其与一排总线引入线相连，绘制好

的总线引入线如图 7-20 所示。 

 
图 7-20  绘制好的总线引入线、放置网络标签后的总线 
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用户也可以直接使用导线 Wire 将总线与元件管脚连接起来，这样操作会显得相对比较麻

烦，放置的引入线也不如使用总线引入线整齐、美观。 

7.1.6  放置网络标签 

添加了总线引入线后，实际上并未在电路图上建立正确的引脚连接关系，此时还需要添

加网络标签（Net Label），网络标签是用来为电气对象分配网络名称的一种符号。在没有实际

连线的情况下，也可以用来将多个信号线连接起来。网络标签可以在图纸中连接相距较远的元

件管脚，使图纸清晰整齐，避免长距离连线造成的识图不便。网络标签可以水平或者垂直放置。

在原理图中，采用相同名称的网络标签标识的多个电气结点，被视为同一条电气网络上的点，

等同于有一条导线将这些点都连接起来了。因此，在绘制复杂电路时，合理地使用网络标签可

以使原理图看起来更加简洁明了。放置网络标签的步骤如下。 
（1）在主菜单中选择 Place→Net Label 命令（快捷键 P，N），如图 7-21 所示，或在工具

栏上选择放置网络标签工具按钮 。  
启动放置网络标签命令后，鼠标指针将变成十字鼠标指针，并在鼠标指针上“悬浮”着

一个默认名为 Net Label 的标签。 
（2）按 Tab 键，打开如图 7-22 所示的 Net Label 对话框。 

   
 图 7-21  选择 Place→Net Label 命令 图 7-22  Net Label 对话框 

（3）单击 Color 色彩块，打开 Choose Color 对话框，在该对话框中选择网络标签的文字

色彩，然后单击 OK 按钮，关闭 Choose Color 对话框。 
（4）单击 Orientation 右侧的文字，在弹出的列表中选择网络标签的旋转角度。 
（5）在 Properties 区域的 Net 下拉列表内设置网络标签的名称：D1。 
（6）单击 Properties 区域内的 Change 按钮，打开“字体”对话框，在“字体”对话框

中设置网络标签的字体，然后单击“字体”对话框中的“确定”按钮，关闭“字体”对话框。 
Altium Designer 系统中，网络标签的字母不区分大小写。在放置过程中，如果网络标签的

最后一个字符为数字，则该数字会按照在 Preferences 对话框的 Graphical Editing 选项页中对

Auto-Increment During Placement 项的设置，自动按指定的数字递增。 
（7）将鼠标指针移到需要放置网络标签的导线上，如 U3 元件的 11 引脚处，当鼠标指针

上显示出红色的星形标记时，表示鼠标指针已捕捉到该导线，单击即可放置一个网络标签。 
如果需要调整网络标签的方向，按空格键，网络标号会逆时针方向旋转 90 度。 
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（8）将鼠标指针移到其他需要放置网络标签的位置，如 U3 元件的 10 引脚的导线上单

击，即放置好 D2 的网络标签（D 后面的数字自动递增），依此方法放置好网络标签 D3～D7。
右击或按 Esc 键，即可结束放置网络标签状态。 

如图 7-20 所示为一个已放置好网络标签的总线的一端。 
（9）用以上方法放置好数码管 DS1～DS3 和电阻 R10～R16 网络标签 D1～D7。 
注意：网络标签名称相同的表示是同一根导线。 
（10）为总线放置网络标签 D[1..7]。 
图 7-23 为放置好网络标签的电路原理图。 

 
图 7-23  放置好的总线、总线引入线及网络标签 

7.1.7  检查原理图 

编辑项目可以检查设计文件中的设计原理图和电气规则的错误，并提供给用户一个排除

错误的环境。 
（1）要编辑数码管显示电路，选择 Project →“Compile PCB Project 数码管显示电

路.PrjPCB”命令。 
（2）当项目被编辑后，任何错误都将显示在 Messages 面板上。如果电路图有严重的错误，

Messages 面板将自动弹出，否则 Messages 面板不出现。如果报告给出错误，则检查用户的电

路并纠正错误。 
项目编译完后，在 Navigator 面板中将列出所有对象的连接关系。如果 Navigator 没有显

示，可选择 View → Workspace Panels → Design Compiler → Navigator 命令或单击工作区窗

口右下角的 Design Compiler 按钮，从弹出菜单选择 Navigator 命令。 
（3）对于已经编译过的原理图文件，用户还可以使用 Navigator 面板选取其中的对象进

行编辑，如图 7-24 所示，是一个原理图文件的 Navigator 面板。 
在该面板上部是该项目所包含的原理图文件的列表，本例中包含一个“数码管显示电路”

的原理图文件。 
在该面板中部是元器件列表，列出了原理图文件中的所有元器件信息，如果用户需要选

择任何一个元件进行修改，可以单击元器件列表中的对应元件编号，即可在工作区选中放大显
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示该元件，且其他元器件将被自动蒙板盖住，如图 7-25 所示，在 Navigator 面板中的元器件列

表中选择了编号为 C1 的电容后，工作区的显示情况。 

 
图 7-24  Navigator 面板 

 
图 7-25  在 Navigator 面板中选择编号为 C1 的电容 

采用这种方法，就能很快地在元器件众多的原理图中定位某个元件。 
在元器件列表的下方，是网络连线列表，显示所有网络连线的名称和应用的范围，单击

任何一个网络名称，在工作区都会放大显示该网络连线，并且使用自动蒙板将其他对象盖住。 
在 Navigator 面板的最下方是端口列表，显示当前所选对象的端口（端口将在层次原理图

中介绍），默认为图纸上的输入、输出端口的信息。当用户在元器件列表或者网络连线列表中

选择一个对象时，端口列表将显示该对象的引脚信息，单击端口列表中的信息时，工作区将会

放大显示该信息，并且使用自动蒙板将其他图元对象盖住。 
数码管原理图绘制正确后，将在第 9 章介绍设计数码管电路的 PCB 图。  

7.2  原理图对象的编辑 

如果用户在绘制原理图的过程中，元件的位置摆放得不好，连接的导线需要移动，可以

采用以下的方法对其进行编辑。 
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7.2.1  对已有导线的编辑 

对已有导线的编辑可有多种方法——移动线端、移动一段、移动整条线或者延长导线到

一个新的位置。用户也可以通过 Wire 对话框中的 Vertices 线端进行编辑、添加或者移除，如

图 7-26 所示。 

 
图 7-26  对线端进行编辑 

1．移动线端 
要移动某一条导线的线端，应该先进中它。将光标定位在用户想要移动的那个线端，此

时光标会变成双箭头的形状。然后单击并拖动该线端到这一个新的位置即可。 
2．移动线段 
用户可以对线的一段进行移动。先选中该导线，并移动光标到用户要移动的那一段上，

此时光标会变为十字箭头的形状，然后单击并拖动该线段到达一个新的位置即可。 
3．移动整条线 
要移动整条线而不是改变它的形态，单击并拖动它之前请不要选中它。 
4．延长导线到一个新的地方 
已有的导线可以延长或者补画。选中导线并定位光标到用户需要移动的线端直到光标变

成双箭头。单击并拖动线端到达一个新位置，在新位置单击。在用户移动光标到一个新位置的

时候，用户可以通过按下 Shift+Space 快捷键来改变放置模式。 
要在相同的方向延长导线，可以在拖动线端的同时按下 Alt 键 。 
5．断线 
使用 Edit→Break Wire 命令来将一条线段断成两段。本命令也可以在光标停留在导线上的

时候，在右键菜单中找到。默认情况下，会显示一个可以放置到需要断开导线上“断线刀架”

标志。被切断的情形如图 7-27 所示。断开的长度就是两段新线段之间的那部分。按下空格键

可以循环切换 3 种截断方式（整线段、栅格尺寸及特定长度）。按 Tab 键来设置特定的切断长

度和其他切断参数。单击以切断导线。右击或者按 Esc 键以退出断线模式。断线选项也可以在

Preferences 对话框下的 Schematic-Break Wire 页面中进行设置。 

 
图 7-27  断线 
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用户可以在 Preferences 对话框下的 Schematic-General 页面中选中 Components Cut Wires
复选框。当此选项和 Optimize Wires & Buses 复选框都被选中的时候，用户可以放置一个元件

到一条导线上，同时线段会自动分成两段而成为这个元件的两个连接端。 
6．拖动多段线 
原理图编辑器中的多线编辑模式允许用户同时延长多根导线。如果多条并行线的结束点

具有相同坐标，可选中那些线（可同时按 Shift+单击）并拖动其中一根线的末端就可以同时拖

动其他线，并且并行线的末端始终保持对准，如图 7-28 所示。 

 
图 7-28  拖动多段线 

7.2.2  移动和拖动原理图对象 

在 Altium Designer 中，移动一个对象就是对它进行重定位而不影响与之相连的其他对象。

例如，移动一个元件不会移动与之连接的任何导线。另一方面，拖动一个元件则会牵动与之连

接的导线，以保持连接性。如果用户需要在移动对象的时候保持导线的电气连接，需要在

Preferences 对话框下的 Schematic-Graphical Editing 页面中选中 Always Drag 复选框。 
1．移动多个对象 
用户可以通过单击和拖动来移动单一的对象，或者是多个已选中的对象。特别地，当用

户想要移动一些对象到另外一些已经放置的对象的上面或者后面的时候，用户也可以使用

Edit→ Move 命令。 
在 Preferences 对话框下的 Schematic-Graphical Editing 页面中的 Object's Electrical Hot Spot

复选框定义了对象在被移动或者拖动时定位在哪里。 
对象被移动时：①按下空格键可以旋转它。旋转是每次 90°的逆时针方向。按 Shift+空格

键可以按顺时针方向旋转。②按 X 或者 Y 键可以使对象分别沿 X 轴和 Y 轴翻转。③按住 Alt
键可以限制移动沿着水平和垂直轴进行。 

2．移动选中的对象 
在原理图文档中，用户可以通过 Ctrl 键和方向键的组合，或者 Ctrl 键、Shift 键和方向键

的组合来移动选中的对象。 
被选中对象的移动是根据Document Options 对话框中的当前的捕获栅格的设置来决定的。

可使用该对话框来修改捕获栅格的值，这些栅格的设置值同时会在 Altium Designer 的状态栏

中显示出来。在 Preferences 对话框下的 Schematic-Grids 页面中还可以设置栅格的公制和英制

预设值。使用 G 键来在不同栅格设置值间切换。用户还可以通过 View → Grids 命令或者右键

菜单中的 Grids 子菜单进行设置。 
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1）被选的对象可以在长按 Ctrl 键时，通过按下方向键进行小步进微动（步进量受限于当

前的捕获栅格的设置值）。 
2）被选的对象也可以在长按 Ctrl 键和 Shift 键时，通过按下方向键进行大步进移动（步

进量为 10 单位栅格）。 
3．拖动对象 
选择 Edit→Move→Drag 命令让用户可以移动任何对象，例如元件、导线或者总线，以及

所有连接线都会随着对象被拖动而移动，以保持原理图上连接属性。当定位光标到被拖动对象

上的时候，光标变成十字准线，然后单击或者按 Enter 键即可开始拖动。移动对象到所需的位

置，并单击或者按 Enter 键完成放置。此后可以继续移动其他对象，或者右击/按下 Esc 键退出

拖动模式。 
要拖动多个被选对象而保持连接性，可以使用 Edit→ Move → Drag Selection 命令。另外，

用户也可以采用快捷键进行对象拖动。单击的同时长按 Ctrl 键，长按左键并移动鼠标，当用

户已经开始拖动时，即可松开 Ctrl 键，对于多个被选对象也是如此。 
拖动对象时：①拖动时，按下空格键可改变连线模式。②移动模式下，按下 Space 键可旋

转对象。旋转是以每步进 90°的逆时针方向进行的。③移动模式下，按下 X 或者 Y 键可分别

让对象沿 X 轴和 Y 轴翻转。④对任何连接到对象的导线，在移动时按下空格键可切换正交走

线模式。 
4．锁定对象不被移动 
要防止原理图对象被意外移动，用户可以通过 Locked 属性来保护它们不被修改（方法：

双击该对象，弹出 Component Properties 对话框，在 Graphical 选项区域选择 Locked 复选框即

可，如图 7-29 所示）。如果用户试图编辑一个被锁定的设计对象，需要在弹出的询问用户是否

需要继续这个动作的对话框中进行确认。 

 
图 7-29  选择 Locked 属性 

提示：如果 Preferences 对话框下的 Schematic－Graphical Editing 页面中的 Protect Locked 
Objects 复选框被选中，则对对象的移动不会有效，同时不会有任何确认提示。当用户试图选

择一系列包括被锁定对象在内的对象时，被锁定的对象将不能被选中。 

7.2.3  使用复制和粘贴 

在原理图编辑器中，用户可以在原理图文档中或者文档间复制和粘贴对象。例如一个文

档中的元件可以被复制到另一个原理图文档中。用户可以复制这些对象到 Windows 剪贴板，

再粘贴到其他文档中。文本可以从 Windows 剪贴板中粘贴到原理图文本框中。用户还可以直

接复制、粘贴诸如 Microsoft Excel 之类的表格型内容，或者复制任何栅格型控件到文档中。通

过智能粘贴可以获得更多的复制/粘贴功能。 
选择用户要复制的对象，通过 Edit→Copy（Ctrl+C）命令和单击以设定粘贴对象时需要精

确定位的那个复制参考点。 
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提示：如果 Preferences 对话框下的 Schematic-Graphical Editing 页面中的 Clipboard  
Reference 复选框被选中，用户会被提示单击一次来设置参考点。 

使用智能粘贴。 
原理图编辑器提供的智能粘贴功能使用户在粘贴对象的时候更灵活。通过单击 Edit 

→Smart Paste 命令来将剪贴板中的对象粘贴出来。例如，用户可以复制一组网络标号并把它们

粘贴为网络标号和导线，如图 7-30 所示。 

 
图 7-30  使用智能粘贴 

7.2.4  标注和重标注 

在 Altium Designer 中，有 3 种方法可以对设计进行标注：原理图级标注、板级标注和 PCB
标注。 

原理图级标注功能允许用户针对参数来设置元件，全部重置或者重置类似对象的标识符。 
在原理图编辑器中，使用 Tools→Annotate Schematics 命令来打开“标注”对话框，如图

7-31 所示，其中用户可以对项目中的所有或已选的部分进行重新分配，以保证它们是连续和

唯一的。 
在标注对话框中按下 F1 键获取关于此过程的更多信息。 
也可以使用 Tools→Annotate Schematics Quietly 命令来为当前未标注的元件指派唯一的标

注，而不用打开“标注”对话框。这个命令遵从用户先前设置好的 Annotate 对话框中的原理

图标注设置。Annotate Schematics Quietly 不会为复制指派唯一的标识符。 
使用 Tools→Reset Schematic Designators 命令可以重置当前工程中所有元器件的标识

符，或者可以通过 Tools→Reset Duplicate Schematic Designators 命令来只重置所有重复的

标识符。 
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图 7-31  “标注”对话框 

依照 Annotate 对话框中的 Schematic Annotation Configuration，使用 Tools→Force Annotate 
All Schematics 命令可以重标注所有元件的标识符。 

反向标注（单击 Tools→Back Annotate Schematics 命令）会根据工程中 PCB 文档的重新标

注来更新项目中的源原理图中的元器件标识符（反向标注在第 11 章进行介绍）。 

7.3  原理图编辑的高级应用 

可以通过以下方式打开对应的属性对话框来查看或者编辑对象的属性。 
（1）当处在放置过程，并且对象浮动在光标上时，按 Tab 键可以打开属性对话框。 
（2）直接双击已放置对象可以打开对象的属性对话框。 
（3）单击主菜单中的 Edit→Change 命令可以进入对象修改模式。单击对象编辑它，也可

以右击或者按 Esc 键退出对象的修改模式。 
（4）单击以选中对象，然后在 SCH Inspector 或者 SCH List 面板中可以编辑对象的属性。 

7.3.1  通过属性对话框编辑顶点 

用户可以通过属性对话框中的 Vertices 选项卡编辑总线、导线、折线和多边形对象的坐标

顶点。例如，导线的属性对话框包含了 Vertics 列表，其中用户可以根据需要编辑已选导线的

起点。 
在图纸的主要区域里，导线的所有顶点都已经被定义了。用户可以为导线增加新的顶点，

编辑已有顶点的坐标，或者移除已有的顶点。 
单击 Menu 按钮以弹出菜单，其中用户可以编辑、增加或者移除顶点，又可以复制、粘贴、

选中或移动图元。Move Wire By XY 命令可以用来移动整条导线对象，从打开的 Move Wire By
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对话框中，可以输入增量值来应用于所有顶点的 X 和 Y 坐标中。 

7.3.2  在 SCH Inspector 面板中编辑对象 

SCH Inspector 面板让用户可以查询和编辑当前或已打开文档的一个或几个设计对象的属

性。使用 SCH Filter 面板（F12 键）或者 Find Similar Objects 命令（Shift＋F 快捷键，或右击

并单击 Find Similar Objects 命令），用户可以对多个同类对象进行修改。 
选中一个或多个对象，并按F11键或者直接单击SCH Inspector标签可以显示SCH Inspector

面板。如果面板不可见，可以单击状态栏上的 SCH 按钮，或者单击 View→Workspace Panels
→SCH→SCH Inspector 命令。用户也可以在 Preferences 对话框下的 Schematic-Graphical Editing
页面中设置 Double Click Runs Inspector 复选框，从而在设计对象中双击而弹出 SCH Inspector
面板，而不是弹出对象属性对话框，如图 7-32 所示。 

 
图 7-32  SCH Inspector 面板 

提示：SCH Inspector 面板只显示所有被选对象的共有的属性。属性清单是可以在 SCH 
Inspector 面板中直接修改的。输入一个新的属性，选中复选框或者单击下拉列表中的选项均

可。按 Enter 键或者单击面板的其他位置以执行这些改动。 
例如要把图 7-1 中的所有电阻的封装从 AXIAL-0.4 变为 AXIAL-0.3，如果依次单个的修改

太麻烦，这时就可以用 SCH Inspector 面板成批的修改。方法如下： 
（1）首先选择一个电阻，右击，从弹出的菜单中选择 Find Similar Objects 命令，弹出 Find 

Similar Objects 对话框，如图 7-33 所示，在 Symbol Reference 的 Res2 处选择 Same，在 Current 
Footprint 的 AXIAL-0.4 处选择 Same，表示选择封装都是 AXIAL-0.4 的电阻，然后单击 Apply
按钮，再单击 OK 按钮，则图 7-1 中的所有电阻被选中，如图 7-34 所示。 
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图 7-33  Find Similar Objects 对话框 

 
图 7-34  选择封装为 AXIAL-0.4 的电阻 

（2）选择 SCH Inspector 面板，在该面板上，将 Current Footprint 处的 AXIAL-0.4 改为

AXIAL-0.3 即可。这时在如图 7-1 所示的原理图上检查每个电阻的封装，它们都为 AXIAL-0.3。 

5.3.3  在 SCH List 面板中编辑对象 

选中一个对象或多个对象并按 Shift＋F12 快捷键来显示 SCH List 面板。在使用 SCH Filter
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面板或者 Find Similar Objects 命令时，用户可以配置和编辑多个设计对象。在 SCH List 面板

中，用户可以通过单击顶部面板的 View/Edit 下拉菜单中的 Edit 命令来改变对象的属性，如图

7-35 所示。 

 
图 7-35  SCH List 面板 

在 SCH List 面板中的 Object Kind 图纸内双击对象以显示它的属性对话框。 

5.3.4  使用过滤器选择批量目标 

在原理图设计过程中，可以使用过滤器批量选择对象，单击编辑窗口右下角的面板转换

按钮 SCH，从弹出菜单中选择 SCH Filter，则会弹出图 7-36 所示的对话框。 

 
图 7-36  SCH Filter 对话框 

在该对话框中，单击 Helper 按钮，则打开如图 7-37 所示的对话框。选择 SCH Function 项

下的 Object Type Checks，右边窗口出现一列条件语句，选择语句 IsPart，则在上面 Query 编辑

框中出现该语句。中间的+、*、Div、Mod、Not 等符号可以组合成复杂的条件语句。单击 OK
按钮，返回 SCH Filter 面板，选中 Select 复选框，单击 Apply 按钮，就可以选择全部元器件。 

 
图 7-37  Query条件语句编辑框 
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在如图 7-36 所示对话框的 Find items matching these criteria 区域内输入不同的语句，就可

以选择相应的对象。如输入 IsBus 语句，然后选中 Select 复选框，单击 Apply 按钮，就可以选

择原理图中的全部总线。 

习题 

1．简述 Altium Designer 在电路原理图中使用 Wire 与 Line 工具画线的区别，原理图中连

线（Wire）与总线（Bus）的区别。 
2．在原理图的绘制过程中，怎样加载和删除库文件？怎样加载 Atmel 公司的 Atmel 

Microcontroller 16-Bit ARM.IntLib 库文件？ 
3．如果要修改某一类元件的属性，用什么面板最方便？ 
4． 和 按钮的作用分别是什么？ 
5． 和 按钮都可以用来放置文字，它们的作用是否相同？ 
6．在元器件属性中，Footprint、Designator、Part Type 分别代表什么含义？ 
7．为了防止原理图中对象被意外移动，应该怎样操作？ 
8．如果原理图中元器件的 Designator 编号混乱，应该怎样操作才能让 Designator 编号

有序？ 
9．绘制如图 7-38 所示的高输入阻抗的仪器放大器电路的电路原理图。 

 
图 7-38  高输入阻抗的仪器放大器电路的电路原理图 

10．绘制如图 7-39 所示的铂电阻测温电路的电路原理图。 



Altium Designer Winter 09 电路设计案例教程 

 150 

 
图 7-39  铂电阻测温电路的电路原理图 

 
 
 


