
2  安装 Android 程序开发工具 

在开始学习设计 Android应用程序之前，必须先打造一个 Android应用程序的开发环境。建立 
Android 应用程序开发环境需要安装一些工具软件，而学习 Android 应用程序设计的一大好处是这 

些工具软件完全免费，只要上网就可以下载。而且这些免费下载的软件，在质量和功能上相较于市 

面上贩卖的商业程序也毫不逊色，并且对于各种操作系统都百分之百支持，包括  Windows  XP、 
Windows Vista、Windows 7、Linux、Mac OS等。 

2­1 不同操作系统的开发工具版本 

因为  Android 是整合目前世界上许多开放源代码技术而成的平台，并不是单一厂商的独家产 

品，因此在安装过程中需要到不同的网站下载软件，并且软件的版本也要谨慎挑选（因为考虑到软 

件间的兼容性），而不像一般商业软件只要运行一个安装程序就大功告成，因此安装过程中需要多 

一点的耐心。不过也毋须太过担心，因为这些开放源代码软件都已经发展得非常成熟，只要依照后 

续的说明一步一步操作即可顺利完成。以下我们就以  Windows 操作系统为例，详细介绍  Android 
程序开发工具的安装过程。 

在开始安装之前让我们先检查一下运行 Android程序开发工具所需的软硬件条件。 就硬件而言 

必须考虑计算机的运行速度和硬盘容量，因为 Android程序开发工具都是使用 Java语言编写，Java 
程序的运行速度比较慢，而且需要占用较多的内存，因此如果 CPU 不够快，或是内存不够大，在 

操作的过程中会经常处于等待的状态，为了能够平顺地运行 Android程序开发工具，所使用的计算 

机必须符合以下所列的最低需求。 

计算机硬件的最低需求 

n  CPU运作速度（频率）：2.5GHz（建议双核以上） 

UNIT 2
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n 内存：2GB 
n 硬盘剩余空间：4GB 
如果读者的计算机是在 3年内购买的新型计算机，应该能够符合以上的条件，如果是旧型的计 

算机，也可以先尝试安装看看，然后再视情况决定是否需要升级。 

软件需求 

软件需求包括操作系统的种类和开发工具的相关软件。 
1．操作系统 

Android程序开发工具支持的Windows操作系统版本包括Windows XP、Windows Vista和 
Windows 7。 

2．Java Development Kit（JDK） 

请读者注意一定要安装 JDK而不能只安装 JRE（JDK包含 JRE），JDK的版本必须是 JDK5 
或 JDK6。 

3．Eclipse 
Eclipse 是由  IBM 捐赠的开放源代码软件，它是一个功能超强的程序开发平台，经过全世 

界开放源代码程序设计人员的通力合作，目前已经发展出支持多种程序语言开发的版本， 

包括 Java、C/C++、PHP、Software  modeling等。我们需要的版本是 Eclipse  IDE  for  Java 
Developers，目前最新版本是 3.7.1，旧版的 3.6也可以和 Android程序开发工具兼容。 

4．Android Development Tools（ADT）plugin for Eclipse 
这是用来编写 Android 程序的工具软件，它是一个 Eclipse 的 plugin（插件），也就是必需 

安装在 Eclipse中和 Eclipse一起运作。 

5．Android Software Development Kit（Android SDK） 
Android  SDK 包括开发 Android 程序的过程中需要用到的资源，像是链接库、程序调试工 

具、平板电脑和手机模拟器等。 

由于Android程序开发工具会持续地更新，在安装之前读者可以先到下列网址查看最新的信息： 

http://developer.android.com/sdk/installing.html 
在了解计算机的软硬件需求之后，接下来就让我们到相关网站下载所需的软件开始进行安 

装吧！ 

2­2 安装 Android 程序开发工具的步骤 

第一步 安装 JDK 

JDK是编写 Java程序必备的工具，如果读者曾经学过 Java程序设计，那么计算机中应该已经
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安装好 JDK。假如不确定或者不知道计算机中安装的 JDK 版本，可以运行 Windows 的“控制台> 
新增或移除程序” ，找找看其中是否有一项叫做“Java SE Development Kit” （旧版的 JDK名称叫做 

“Java 2 SDK, SE” ）。如果找到了（注意版本必须是 5或 6）代表计算机中已经安装好 JDK，那么 

就可以跳过这一个步骤。如果找不到或是版本比 5 或 6 还低，请先将旧版的 JDK 移除，然后依照 

下列说明安装新的版本。 

请开启网页浏览器在网址列输入下列网址，或是利用 Google搜索 JDK再从中选择下列网址： 

http://www.oracle.com/technetwork/java/javase/downloads/index.html 
开启以上网址后会看到如图 2­1所示的网页， 如果读者看到的网页编排和书上的图有些不同也 

不用担心，因为网页上的数据随时都有可能更新，但是内容基本上是相同的。如果读者仔细看一下 

目前最新的版本号码，会发现已经是 JDK 7，与 Android网站建议的版本不同，如果将网页往下拉 

就可以找到 JDK 6的版本，然后单击 JDK Download按钮，之后就会出现图 2­2的界面。在网页下 

方有各种操作系统的 JDK 安装文件，请先单击同意遵守版权的项目，再选择适合的操作系统版本 

进行下载，等下载完成之后直接运行下载的文件就可以完成安装。 

图 2­1  Java的官方网页，请单击 JDK Download按钮下载 JDK 

第二步 安装 Eclipse 

Eclipse 是一个通用的程序开发平台，不仅功能强大，还有一个优点就是不需要安装，只要把 

它解压缩到一个新的文件夹就可以运行。这就是所谓的绿色软件，它不会随意变更计算机的设置， 

也不会在移除之后留下任何额外的文件。首先我们到 Eclipse 的官方网站，请读者开启网页浏览器 

单击下载 
JDK
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在网址列输入下列网址，或是利用 Google搜索 Eclipse再从中选择下列网址： 

http://www.eclipse.org/ 

图 2­2  选择符合操作系统的 JDK版本 

开启该网址后就会看到如图 2­3的界面， 请单击右上方的Download Eclipse按钮就会进入图 2­4 
的网页，请单击其中的 Eclipse IDE for Java Developers项目进入图 2­5的界面，最后从右边的版本 

列表中选择适合的操作系统版本进行下载。 

图 2­3  Eclipse开发工具的官方网站 

选择适合的 

文件下载 

操作系 

统版本 

点选进入 

下载页面
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图 2­4  下载 Eclipse的网页界面 

图 2­5  选择我们需要的 Eclipse IDE for Java Developers版本 

完成下载后请建立一个新的文件夹， 例如可以在 C:\Program Files中新增一个名为 Eclipse的文 

件夹， 然后把下载的 zip文件全部解压缩到该文件夹即可完成 Eclipse的安装。 当要启动 Eclipse时， 

只要运行其中的 eclipse.exe即可。为了日后使用上的方便，读者可以在桌面上建立一个 eclipse.exe 
文件的快捷方式。 

安装 Android程序开发工具的注意事项 

在建立 Eclipse 文件夹的路径中（包括从驱动器号开始）不要有任何的中文名称，否则在运行开发工具的过 

程中可能会出现不明原因的错误。 

目前的 

版本 

旧的 

版本 

选择适合的 

版本下载 

补充说明
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第三步 安装 Android Development Tools (ADT) plugin for Eclipse 

ADT plugin  for Eclipse可以在 Eclipse主程序中完成下载和安装。首先运行上一个步骤安装好 

的 eclipse.exe，然后选择 Help>Install New Software就会出现图 2­6所示的对话框，按下对话框右上 

方的 Add按钮并输入下列信息。 

n  Name: Android plugin 
n  Location: https://dl­ssl.google.com/android/eclipse/ 

图 2­6  在 Eclipse中安装 ADT plugin for Eclipse的界面 

单击 OK 按钮，在对话框中央的列表会出现 Developer  Tools 项目。如果没有出现，请读者再 

重新单击 Add按钮，把 Location 改为 http://dl­ssl.google.com/android/eclipse/（也就是把原来的 https 
改成 http）应该就会出现 Developer Tools。把该项目打勾然后依照说明操作就可以完成安装。安装 

后会显示一个对话框要求重新启动 Eclipse，单击 Restart  Now重新启动即可，当 Eclipse重新启动 

之后会显示一个对话框询问安装 Android SDK的事项，请读者参考下一个步骤继续操作。 

第四步 安装 Android Software Development Kit（Android SDK） 

完成上一个步骤之后会显示图 2­7的对话框让我们继续安装 Android SDK，请读者选择 Install 
new SDK，然后勾选 Install the latest available version of Android APIs，在下方的 Target Location 字 

段中设置好 Android  SDK的储存路径，然后单击 Next按钮就会出现图 2­8所示的对话框，左边会 

列出要安装的项目，确认无误后单击 Install按钮开始安装。 

单击 Add按钮
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图 2­7  Eclipse显示安装 Android SDK的对话框 

图 2­8  Android SDK安装过程中的项目说明 

Android SDK的储存路径 

1．在 Android SDK 的储存路径中不要出现任何中文文件夹名称，否则在开发 Android 程序时会出现错误信 

息。 
2．我们可以将 Android SDK 存放在 Eclipse文件夹中，这样安装好开发环境之后就可以将整个 Eclipse文件 

夹压缩复制到 U盘，然后在任何一台含有 JDK 的计算机上将 Eclipse文件夹解压缩到任何一个文件夹， 

再依照后续的说明完成两项设置就可以开始开发 Android 程序。 

如果读者顺利完成上述的操作就可以跳到下一个步骤， 如果安装过程中出现错误， 则可以改用 

下列方式安装。请开启网页浏览器在网址列输入下列网址，或是利用 Google搜索 Android SDK再 

从中选择下列网址。 

② 单击  Browse 按钮 

选择安装的文件 

夹（参考“补充说 

明” ） 

③ 单击 Next按钮 

① 选择这一项 

① 点选 Accept All 

② 单击 Install按钮 

补充说明
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http://developer.android.com/sdk/index.html 
开启该网址后会出现图  2­9 的网页，网页上会列出不同操作系统的  Android  SDK 版本。以 

Windows操作系统来说，官方网站推荐使用 installer_r15­windows.exe，因此我们单击该文件进行下 

载，然后运行该文件。首先会显示一个确认 JDK 版本的对话框，单击 Next 按钮会显示图 2­10 的 

界面让我们设置 Android SDK的储存路径，设置好之后单击 Next按钮决定快捷方式的位置，如果 

不想建立快捷方式可以勾选下方的 Do not create shortcuts，然后单击 Install按钮进行安装。安装完 

成后会询问是否运行 SDK Manager，勾选该项目继续运行 SDK Manager。 

图 2­9  Android SDK的官方网站 

图 2­10  设置 Android SDK的储存路径 

启动 SDK Manager 之后会看到图 2­11的对话框，其中有许多可以展开的项目，包括一些相关 

工具程序和组件，以及不同版本的 Android SDK，每一个项目的后面都会显示安装状态。读者可以 

勾选需要安装的项目，再按下右下方 Install packages按钮进行安装，由于这个步骤需要下载大量的 

下载此文件 

① 单击 Browse按钮 

选择安装的文件夹 

② 单击 Next按钮
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数据，如果网络速度不够快，可能需要等待一段时间，完成后关闭对话框。 

使用 Android SDK Manager 

图 2­11是 Android SDK Manager 的操作界面，往后如果我们需要安装其他版本的 Android SDK 或是删除已 

经安装的版本都必须通过它来完成。需要运行 Android  SDK  Manager 时先启动 Eclipse，然后选择主选单的 
Window > Android SDK Manager。 

图 2­11  SDK Manager操作界面 

最后还必须在 Eclipse中设置 Android SDK的路径才可以使用，请读者运行 Eclipse，单击选单 

上的 Window>Preferences 便会出现图 2­12 的对话框，在对话框的左边单击 Android 项目，然后在 

右边的 SDK Location 中填上 Android SDK的储存路径（也可以使用右边的 Browse按钮来选择）， 

最后单击下方的 Apply按钮，再单击 OK按钮。 

第五步 建立 Android Virtual Device（AVD） 

AVD 就是 Android 的设备模拟器，在编写 Android 应用程序的过程中，我们必须让程序在模 

拟器中运行才可以看到结果。请先运行 Eclipse，单击主选单的“Window>AVD Manager”就会出 

现图 2­13 的对话框，单击对话框右上方的 New 按钮便会出现图 2­14 的对话框，在 Name 字段中 

帮这个虚拟设备取一个名称，在 Target 字段中选择一个 Android 版本，在下方的字段还可以指定 
SD 卡的容量、设备的屏幕大小和分辨率。如果在 Target 字段挑选的是 Android 4.0 以上的版本， 

那么所设置的屏幕大小和分辨率决定究竟这是手机模拟器还是平板电脑模拟器。在  Skin 字段中 

补充说明
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我们可以选择一个内建的屏幕型号，或是自行设置屏幕的宽和高，然后在  Hardware 字段中可以 

设置 Abstracted LCD density，这二者的搭配结果决定模拟器的屏幕尺寸。请读者参考表 2­1，它 

是 Android SDK 用来分类屏幕尺寸的方式，上方第一列就是 Abstracted  LCD  density的值，表格 

中就是 Skin 字段设置的屏幕型号或是自行输入的宽和高。假设在 Skin 字段选择 WVGA800（480 
×800） ，然后将 Abstracted LCD density设置成 160，那么模拟器的屏幕尺寸分类就是 Large，可 

是如果将  Abstracted  LCD  density 换成  240，那么模拟器的屏幕尺寸分类就变成  Normal。对于 
Android 4.0 以上来说，屏幕尺寸分类为 Small、Normal 和 Large 的都是手机模拟器，屏幕尺寸分 

类为 Extra Large的才是平板电脑模拟器。如果 Target 字段是设置 Android 3.X 则一律是平板电脑 

模拟器，如果 Target 字段是设置 Android  2.X 或 1.X 则一律是手机模拟器。设置好模拟器的属性 

之后，按下 Create  AVD 按钮就完成新增模拟器的动作。视情况需要我们可以建立多个不同型态 

的模拟器，以便测试程序在各种设备的运行结果。 

图 2­12  设置 Eclipse的 Android SDK文件夹路径 

图 2­13  新增模拟器的对话框 

① 单击 Browse按钮 

选择 Android SDK 
的文件夹 

② 单击 Apply按钮 

③ 单击 OK按钮 

单击 New按钮 

新增 Android 模拟器 

已经建立好的 
Android 模拟器



拥抱 Android  PART  1 

19 

1
 

PA
R

T
 

图 2­14  设置模拟器的名称和属性 

表 2­1  模拟器屏幕尺寸的分类 

屏幕尺寸 

的分类 
Low density 
(120), ldpi 

Medium density (160), 
mdpi 

High density 
(240), hdpi 

Extra high 
density 

(320), xhdpi 

Small  QVGA（240×320）  480×640 

Normal 
WQVGA400（240×400） 

WQVGA432（240×432） 
HVGA（320×480） 

WVGA800（480×800） 

WVGA854（480×854） 

600×1024 

640×960 

Large 
WVGA800（480×800） 

WVGA854（480×854） 

WVGA800（480×800） 

WVGA854（480×854） 

600×1024 

Extra Large  1024×600 

WXGA（1280×800） 

1024×768 

1280×768 

1536×1152 

1920×1152 

1920×1200 

2048×1536 

2560×1536 

2560×1600 

完成上述的所有步骤之后，安装 Android程序开发工具的任务就大功告成了。如果读者的计算 

机是使用 Linux操作系统或是Mac系列的计算机， 安装Android程序开发工具的过程和以上介绍的 

步骤类似，只是在软件版本的选择上要挑选适合的操作系统版本，请读者同样依照上述步骤操作即 

可顺利完成安装。 

⑤ 单击 Create AVD按钮完成 

新增模拟器 

④ 设定模拟器的屏幕型式 

③ 设定 SD Card容量 

（如果不需要可省略） 

② 挑选模拟器的 Android版本 
① 输入模拟器名称
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2­3    Android 程序开发工具的维护和更新 

Android程序开发工具包含许多不同来源的软件，这些软件会不断地推陈出新。如果我们需要 

更新其中某一个软件， 或是觉得系统有问题想移除某一个软件再重新安装该怎么办呢？以下我们以 
Windows版本的开发工具为例来加以说明。 

1．移除 JDK再重新安装 

移除前如果要先检查计算机中安装的 JDK版本可以运行Windows的“控制面板>添加或删 

除程序” ，寻找其中名为 Java SE Development Kit的项目。该项目名称的后面会有一个数字 

代表版本号码 （例如 5或 6）， 如果想要移除旧的版本， 可以先用鼠标单击它， 然后单击 “移 

除”按钮。 

要安装新版的 JDK，首先要连到 JDK 的官方网站下载想要的 JDK 版本，然后运行它的运 

行文件即可完成安装。 

2．移除 Eclipse再重新安装 
Eclipse是一个绿色软件，只要把它复制到计算机磁盘中就可以运行。如果想要移除它，也 

只要删除它所在的文件夹即可。但是请注意，如果 Android SDK是放在 Eclipse文件夹中， 

记得先把它复制出来，等重新安装好 Eclipse之后再复制回去，并依照前面第四步骤最后的 

说明设置好 Android SDK的路径。 

3．移除 ADT plugin for Eclipse再重新安装 

运行 Eclipse然后单击菜单 Help>About Eclipse，在出现的对话框中单击 Installation Details 
按钮就会出现图  2­15 的对话框。在对话框中会列出安装在  Eclipse 中的工具，请找出 

“Android DDMS” 、 “Android Development Tools” 、 “Android Hierarchy Viewer”和“Android 
Traceview”4个项目，选择它们后（可以同时按住键盘上的 Ctrl键进行多重选择）单击下 

方的 Uninstall 按钮就可移除。如果是想要更新，就单击 Update 按钮。移除后要重新安装 

请参阅前面的安装步骤重新做一次即可。 

4．移除 Android SDK再重新安装 

先删除储存 Android SDK的文件夹， 然后依照前面介绍的安装步骤重新安装 Android SDK。 

如果是要更新， 可以参考前面的 “补充说明” 运行 Android SDK Manager， 在对话框的 Status 
字段会列出可以更新的项目，勾选需要更新的项目后单击右下方的 Install packages按钮进 

行安装。 

5．移动 Eclipse程序的文件夹 

安装好 Android 程序开发工具之后，如果有一天突然想把 Eclipse 程序的文件夹搬到其他 

地方也可以，只不过如果 Android  SDK 是放在 Eclipse 文件夹中，在移动 Eclipse程序文 

件夹之后必须重新设置 Android  SDK 的文件夹路径，请读者依照前面第四步骤最后的说
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明操作即可。 

图 2­15  移除或更新 ADT plugin for Eclipse的操作界面 

① 点选要移除或 

更新的程序， 

可按下 Ctrl键 

进行多选 

② 如果要更新单击 
Update按钮， 

如果要移除单击 
Uninstall按钮



3  建立 Android 应用程序项目 

在完成程序开发工具的安装之后， 读者是不是迫不及待想试用看看呢？第一次使用新东西总是 

让人感到特别地新鲜和期待，现在就让我们来体验一下Android应用程序的开发流程吧！ 

建立 Android应用程序项目的过程和建立一般 PC程序项目的过程大致相同，如果读者已经具 

备编写计算机程序的经验应该很容易就能够上手， 如果读者还不熟悉计算机程序的开发也无妨，只 

要依照下列说明一步一步操作，就能够顺利完成第一个Android应用程序。 

运行 Eclipse程序。 

从选单中选择 File > New > Project就会出现图 3­1所示的对话框。 

图 3­1  建立新程序项目的对话框 

UNIT 3 Android 版本  1.X  2.X  3.X  4.X 

适用性 ★ ★ ★ ★
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在对话框中间的清单中单击 Android > Android  Project，再单击 Next按钮就会出现图 3­2 
所示的对话框。 

图 3­2  设置 Android应用程序项目的属性–步骤一 

输入以下信息： 
1．Project Name：自己帮此项目取一个名字，例如 first。 
2．单击 Create new project in workspace项目。 
3．勾选 Use default location。 

单击 Next按钮就会出现图 3­3的对话框。 

图 3­3  设置 Android应用程序项目的属性–步骤二 

选择此程序项目使用的 Android平台版本（Build Target），例如勾选 Android 4.0，然后单 

③ 单击 Next按钮 

② 点选这一项 

① 输入项目名称
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击 Next按钮就会出现图 3­4的对话框。 

图 3­4  设置 Android应用程序项目的属性– 步骤三 

继续输入以下信息： 
1．Application Name：当此程序运行时，显示在屏幕上方的标题，例如可以填上“我的第 

一个 Android应用程序” 。 
2．Package Name：就字义上来说是组件名称，但其实这个字段是决定程序文件在项目文 

件夹中的储存路径，它是用网址的格式代表，但是是从大区域到小区域而不是网址惯 

用的小区域到大区域，例如可以填上 tw.android，注意至少要有两层，也就是 xxx.xxx。 
3．Create Activity：这是程序的主类名称，主类就是程序开始运行的地方，这个主类是继 

承 Activity类，例如读者可以输入Main。 
4．Minimum SDK：限制这个程序项目必须在哪一个版本以上的 Android平台上运行，读 

者可以从下拉式菜单中选择一个 Android版本， 这个字段是使用 API Level编号也就是 
3, 4, 5, …代表， 每一个 Android平台版本都会有一个 API Level编号， 在 Android SDK 
技术文件中经常以 API Level标号来描述 Android平台的版本， 因此建议读者留意它们 

之间的对应关系。 

最后单击 Finish按钮就完成建立 Android程序项目的步骤。 

建立 Android程序项目的注意事项 

1．程序项目的 Project Name不可以使用中文。 
2．程序项目的 Application Name可以使用中文。 
3．Android 3.0（API Level 11）是 Android 平台发展过程中的重要分界，在 Android 3.0 以前都是手机程序， 

Android  3.X 则是平板电脑程序，Android  4.0 以后才是手机和平板电脑的通用版本，因此如果我们将 
Minimum SDK 字段设置为 11 以下，就代表此程序项目是属于旧 Android 版本的手机程序，如果设置成 

补充说明
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11～13（13是 Android 3.2 的 API Level编号）就是平板电脑程序，设置成 14以上才是手机和平板电脑 

的通用程序。 

建立好程序项目之后单击上方工具栏的 Run 按钮就会出现图 3­5所示的对话框， 它是用来设置 

程序的运行模式，每一个程序项目第一次运行的时候都会出现这个对话框，请读者选择  Android 
Application 再单击 OK按钮。如果读者依照上一个单元的说明分别建立了 Android 4的手机和平板 

电脑模拟器，可以让这个程序项目分别在这两个模拟器上运行，就可以看到如图 3­6和图 3­7所示 

的运行界面。如果读者没有事先启动 Android模拟器，第一次运行程序时会需要比较长的时间（可 

能数分钟），因为 Eclipse必须先启动 Android模拟器并等待启动完成，然后才能在上面运行程序。 

图 3­5  选择 Android程序项目的运行模式 图 3­6  在 Android 4手机模拟器上的运行界面 

图 3­7  在 Android 4平板电脑模拟器上的运行界面
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3­1 修改程序的接口 

虽然我们已经完成了第一个 Android应用程序，也看到了运行结果，可是还是觉得有些意犹未 

尽，因为我们并没有写任何程序代码，只是按几下鼠标输入几个文字罢了，整个程序从哪里开始运 

行到哪里结束还是没有头绪！没关系，接下来就让我们为程序加油添醋一下吧。 

请用鼠标单击 Eclipse左边项目检查窗口中的项目名称将项目展开，如图 3­8所示。 

图 3­8  在 Eclipse左边的项目检查窗口中展开项目内容 

项目名称下面有几个文件夹，请打开其中的 res文件夹，然后打开里头的 values文件夹， 

再用鼠标双击 strings.xml 文件，该文件便会出现在 Eclipse 中央的程序代码编辑窗口（请 

参考图 3­8）。 

strings.xml是程序项目的字符串资源文件，它有两种编辑模式，读者可以在程序代码编辑 

窗口左下方找到两个小小的标签并用它们进行切换，第一种是 Design 模式，这是利用类 

似表格字段的方法，配合阶层状的展开模式进行编辑。第二种是  Source 模式，它是用原 

始的文本文件进行编辑。请读者使用 Source模式将 hello字符串的内容改成“你好，这个 

程序的主要类名称叫做Main”，如下： 

<?xml version="1.0" encoding="utf­8"?> 
<resources> 

<string name="hello">你好，这个程序的主要类名称叫做Main</string> 
<string name="app_name">我的第一个 Android应用程序</string> 

</resources> 

字符串资源文件
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仿照第二步的方法打开 res/layout/main.xml文件。 

在最后一行的上方，也就是</LinearLayout>的上一行插入下列的程序代码，输入时请注意 

遵守原来文件的锯齿状编排格式以方便阅读程序代码。如果程序项目是使用Android 2.2以 

后的版本，可以把 fill_parent改成match_parent。 

<Button 
android:layout_width="fill_parent" 
android:layout_height="wrap_content" 
android:text="这是按钮" 
/> 

<ImageButton 
android:layout_width="fill_parent" 
android:layout_height="wrap_content" 
android:src="@drawable/ic_launcher" 
/> 

接口布局文件的编辑技巧 

res/layout/main.xml是程序运行界面的定义文件，我们可以称它为“接口布局文件” ，其中可以加入各式各样 

的接口组件。在设置接口组件的属性时，每一次输入“android:”之后稍停半秒钟就会自动弹出一个属性列 

表（如果没有请先关闭文件，再用鼠标右击该接口布局文件，从快捷菜单中选择 Open With > Android Layout 
Editor），我们可以继续输入属性名称的前几个字母，列表中会自动过滤出符合的属性，如果单击列表中的属 

性，还会出现另一个窗口说明该属性的效果。善用这项功能不但可以减少打错字的机会，还可以学到许多不 

同属性的用法。 

完成后请读者按下上方工具栏中的  Run 按钮，再分别选取手机模拟器和平板电脑模拟器来运 

行程序，就可以看到如图 3­9和图 3­10的结果。读者可以发现程序显示的信息改变了，而且多了 2 
个按钮。读者可以按下其中任何一个按钮，只是不会有任何效果，因为我们并没有加上处理按钮的 

程序代码，这一部分我们留待后续单元再作介绍。根据以上的操作，读者是不是对 Android程序开 

始有一些感觉了呢？ 

图 3­9  修改后的程序在 Android 4手机模拟器上的运行界面 

补充说明
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图 3­10  修改后的程序在 Android 4平板电脑模拟器上的运行界面 

Android模拟的使用技巧 

如果想要结束在模拟器上运行的程序，可以按下模拟器的“回上一页”按钮， “回上一页”按钮是一个类似 

“回转”的半圆型箭头。如果我们结束模拟器，等一下再运行程序时必须重新将它启动，这将会很耗时间。 

补充说明


